Организовано приемочное тестирование, аналогичное тестированию 1C в проекте xUnitFor1C

Для запуска тестов используется скрипт testrunner.os.

Скрипт выполняет последовательный прогон тестов, переданных в командной строке.

Запуск тестов

Формат командной строки:

oscript tests\testrunner.os [-command] testfile|testdir [test-id|test-number] [-option [optionData]]

Виды команд

  • -show - вывод доступных тестов с именами тестов и номерами тестов по порядку объявления
  • -run - прогон всех тестов из файла теста или одного конкретного теста, уточненного по номеру или наименованию
  • -runall - прогон всех тестов из каталога, в т.ч. и из вложенных каталогов

Виды режимов

  • xddReportPath - формировать отчет тестирования в формате junit-xml
    • [optionData] - полный или относительный путь к каталогу, где формировать файл *.xml

Примеры:

  • oscript tests\testrunner.os -show testfile - вывод списка тестов

  • oscript tests\testrunner.os testfile или oscript tests\testrunner.os -run testfile - запуск всех тестов из файла

  • oscript tests\testrunner.os -run testfile 5 или oscript tests\testrunner.os testfile 5 - запуск теста №5

  • oscript tests\testrunner.os -run testfile "Тест1" или oscript tests\testrunner.os testfile "Тест1"- запуск теста с именем Тест1

  • oscript tests\testrunner.os -runall tests - запуск всех тестов из каталога tests

  • oscript tests\testrunner.os -runall tests xddReportPath . - запуск всех тестов из каталога tests и формирование отчета тестирования в формате junit-xml

Формат скриптов-тестов

Тесты находятся в каталоге tests

Пример скрипта-теста находится в tests\example-test.os :

Перем юТест;

// основной метод для тестирования
Функция ПолучитьСписокТестов(ЮнитТестирование) Экспорт
	
	юТест = ЮнитТестирование;
	
	ВсеТесты = Новый Массив;
	
	ВсеТесты.Добавить("ТестДолжен_ПроверитьВерсию");
	
	Возврат ВсеТесты;
КонецФункции

Процедура ТестДолжен_ПроверитьВерсию() Экспорт
	юТест.ПроверитьРавенство("0.1", Версия());
КонецПроцедуры

Функция Версия() Экспорт
	Возврат "0.1";
КонецФункции

Механизм работы с временными файлами

В testrunner.os встроен механизм работы с временными файлами. Удобен для автосоздания и автоудаления файлов после выполнения тестов. Вызывать через юТест.

Методы:

  • ИмяВременногоФайла() - возвращается имя временного файла и имя фиксируется для дальнейшего удаления
  • УдалитьВременныеФайлы() - удаляются все зарегистрированные ранее временные файлы
  • Удобно этот метод использовать в 'ПослеЗапускаТеста'

#Запуск тестирования из Notepad++

в Notepad++ (для плагина NppExec) можно использовать следующую команду:

oscript testrunner.os "$(FULL_CURRENT_PATH)" 

В случае ошибок в тестах/файле будет выдано окно консоли с описанием ошибки.